Announcement

Collapse
No announcement yet.

User Profile

Collapse

Profile Sidebar

Collapse
Avatar
Spike04
Junior Member
Last Activity: 12-10-2019, 03:18 PM
Joined: 11-29-2019
Location: Nebraska
  •  
  • Filter
  • Time
  • Show
  • Source
Clear All
new posts

  • Spike04
    replied to Handler 100 arrived broken...
    Google "Hobart not feeding wire". Many other people trying to figure out why their feeder stopped, or isn't working brand new. A lot never do figure it out so they have to take their unit in for repair. A lot of 'fans run, no feed' issues people are trying to troubleshoot. Not going to share...
    See more | Go to post

    Leave a comment:


  • Spike04
    replied to Handler 100 arrived broken...
    Had these exact thoughts. I actually work for a company that manufacturers circuit boards. Hoping to find some aluminum spares to repair it with....
    See more | Go to post

    Leave a comment:


  • Spike04
    replied to Handler 100 arrived broken...
    For sure is possible, and that is likely what happened. But that is a heavily populated circuit board with some heavy components (notice that big coil) being held vertical by pathetically placed plastic, rolling the welder on a cart could cause those standoffs to break. Terrible manufacturing design,...
    See more | Go to post

    Leave a comment:


  • Spike04
    started a topic Handler 100 arrived broken...

    Handler 100 arrived broken...

    Was so excited to get a new welder today, nothing fancy, Hobart Handler 100, but was just really looking forward to getting it up and running. Came today FedEx, got it all opened and ready to go. Put wire on and the wire feeder had no power. Spent the next hour or more reading the manual and googling...
    See more | Go to post
No activity results to display
Show More
Working...
X