Announcement

Collapse
No announcement yet.

User Profile

Collapse

Profile Sidebar

Collapse
Profile Picture
steve nmi
Junior Member
Last Activity: Yesterday, 08:30 PM
Joined: 03-07-2004
Location: Petoskey Mi.
  • Filter
  • Time
  • Show
  • Source
Clear All
new posts

  • steve nmi
    replied to Help with my hobart 140 Mig!!
    If the product specifies 20 amp then you need 20 amp Check your fuse panel and find a 20 amp circuit you can plug into. Usually there is one for the kitchen or garage. If there isn't one then you will need to add one if the panel has room.
    See more | Go to post

    Leave a comment:


  • I tested the diodes and the one on the left side, the one that connects to the ground clamp is shorted and the one on the right side only flows in one direction. I don't know if the diode is the only problem but the one is bad so I guess I'll have to change it and go on from there. I'm still not sure...
    See more | Go to post

    Leave a comment:


  • Thank You Dale for your recommendation. I'll go with this, it looks like it's quite substantial, could you please let me know how you came up with this particular part? Also I'm thinking about changing both of the diodes which are identical parts.
    Most of the things I've read on the internet...
    See more | Go to post

    Leave a comment:


  • steve nmi
    started a topic Snap on YA 219 110V Mig Welder Diodes

    Snap on YA 219 110V Mig Welder Diodes

    I have a older Snap On YA 219 110V Mig Welder that just quit working. I was welding yesterday and all of a sudden it started buzzing very loud and then tripped the breaker. I heard before that diodes go bad frequently in these machines so checked these and one of them is open both directions. Searching...
    See more | Go to post
No activity results to display
Show More
Working...
X