Announcement

Collapse
No announcement yet.

Beta Mig 250

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • BetaMig250
    started a topic Beta Mig 250

    Beta Mig 250

    I have an old Beta Mig 250. For some reason everytime I press the trigger it blows the breaker. Has anyone else experienced this? I am hoping it has not laid it's last bead! Opened the case up and everything looks surprisingly good, although the transformer is a little rusty on the top side. Any help and suggestions would be greatly appreciated. It welded Steel, Stainless, and Aluminum perfectly for years.

  • Hobart Expert Keith
    replied
    Is the unit being used on the same service as before? Same breaker, same service run, same outlet?

    Leave a comment:


  • BetaMig250
    replied
    Coxhaus thanks for the reply! That was my first thought too. I tried it on three different circuits and had the same results. Then tried my plasma on same circuits and it worked fine. I'll separate the lines on my plasma at the plug and check the amperage then do the same on the mig. It's holding pressure on the gas line and will pop an arc then trips the breaker. It will trip even if not trying to weld. Was hoping someone on here might be able to help, since I have not found anyone close that even knows what a Beta-Mig is to try and repair it. I've called the manufacturer of the transformer and they referred me to Hobart, have not had success getting in touch with them. Tried to purchase a wiring diagram and bought one for another welder even though it was labeled 250. I've had it for twenty years and really hate to scrap it!

    Leave a comment:


  • coxhaus
    replied
    Before you claim the welder is bad you might try swapping the breaker to make sure it did not go bad.

    Leave a comment:

Working...
X