Announcement

Collapse
No announcement yet.

Hobart TG-301 Amperage Control

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hobart TG-301 Amperage Control

    Hi all new guy here with problems that I'm hoping the community can help me fix. I have an ancient Hobart TG-301 that has worked pretty much flawlessly for the better part of 7 years. It welds any project that I have without issue until lately. I cant control the amperage through the foot pedal anymore. I took the pedal apart and cleaned the rheostat and even though it ohm checked decently I replaced it with a new unit with the same result. Dependent upon what amperage level is selected on the machine I'm getting either the bottom or the top of the voltage range within that selection no in between what so ever. Can anyone point in the right direction to fix my issue? Please and Thanks

    Hobart TG-301
    serial 12rt-19996
    specs 4813a

  • #2
    Check your email for a manual and test sheet.

    Comment


    • #3
      Thanks for your reply as well as the info Keith. So as I stated previously I replaced my rheostat in the pedal and I looked at the trouble shooting guide writhing the manual and it said to check the lower fuse in the face panel. It was blown I replaced it and attempted to weld and the outcome was almost the same but what I did notice was that if I remove the fuse the torch is hotter. If I install the fuse it doesn' get very hot at the same setting? What else do you recommend me checking?

      Comment


      • #4
        Check all the voltages on the MAG amp, labeled SR on the schematic, in and out on the test sheet I included. This is your current control portion of the machine.

        Comment

        Working...
        X