Announcement

Collapse
No announcement yet.

Hobart Handler 190 stopped feeding wire?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Hobart Handler 190 stopped feeding wire?

    I have searched high and low on Google and YouTube, but I cannot figure out the problem with my machine.
    I bought it new and have been the only owner.

    It has been a good machine but recently on my latest project stopped feeding wire. I thought maybe I hit the duty cycle, so I waited and waited, but it never worked again.

    I was able to run the feed motor by disconnecting the wires from the circuit board and jump the motor with an alternate power source. It worked flawlessly.

    I tested the potentiometer (rheostat) thinking maybe this is the simple fix. It is in great working order. Smooth resistance from low to high in both directions (tested with a multimeter).

    I saw one possible fix was the transistor on the circuit board, so I thought, ok. I'll order the "common issues" kit off of eBay, and solder a new transistor on. This did not fix the issue either.

    The last thing I can think of was a whole new circuit board. So that's just what I did. I ordered from ifexport.com. Finally got that in, and it still has yet to solve the issue.

    I must be missing something simple?? Can anyone help out with some ideas?
    The relay still clicks when I pull the trigger like normal, and the tip is still "hot" when the trigger is pulled. I cannot figure out why it will not feed the wire. I hope someone can help

    My only other plan now is to buy a new welder, but I was hoping to not have to. If I did I was looking at the Ironman 230 or 240, but I will make another post for this idea, as I have my own questions and reservations about that.

    Thanks all.

  • #2
    Did you check spool gun switch?

    Dale
    "Fear The Government That Wants To Take Your Guns" - Thomas Jefferson..

    Comment


    • #3
      If you know how to use the multimeter safely, you should be able to find where the power to the motor is being interrupted, following its path throughout the machine.

      Comment


      • #4


        Yeah, I found it now. After trying for several days, I now see I had hit the spool gun switch inside. I think it was the transistor that first might have went out when I was mid-welding one on my project the other day, and then when I was fooling with it originally when it was actually malfunctioning, I forgot to switch it back to the feed gun instead of the spool gun. Gosh, I feel like a big idiot, but maybe someone will be able to see this in the future and save themselves the headache I gave myself.
        If I had seen that after the first transistor fix, before running through all the other stuff, I probably would have been back in progress already. At any rate, I think I will see how it welds tomorrow (it's midnight, don't feel like messing with it now) and decide if I need to upgrade still. I've been using that machine a lot, might just keep it for the aluminum spool gun and upgrade anyway to the Ironman 240 if it keeps getting good reviews. I can't find an Ironman 230 anywhere in my area anymore but hopefully the 240 is just as reliable and even better!

        Thanks for the concern and help. If I run into any other issues, I'll be sure to make a fool of myself again!

        Comment


        • #5
          Originally posted by MAC702 View Post
          If you know how to use the multimeter safely, you should be able to find where the power to the motor is being interrupted, following its path throughout the machine.
          As simple as this would have been, I forgot to do this.
          I was messing with it after it broke, and I forgot to switch it back after I did my fixes. Thank you for giving me a little bit of common sense, I am really in need of it. O_O

          Comment


          • #6
            That switch has probably caused more "problems" than it solved. I have to remember to keep thinking of asking about it when we get these questions.

            Comment

            Working...
            X