Announcement

Collapse
No announcement yet.

Trouble with miller 12vs and 325 trailblazer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble with miller 12vs and 325 trailblazer

    Hi all, am trying to get ready to hit the road, no experience with a 12vs before but trying to get it to work as it is more efficient? then stick.
    Plugged everything in as miller recommends, problem is suitcase is trying to put out 60 or 65 volts no matter where I set the trailblazer.
    any help appreciated!

    Mason

  • #2
    Set your trailblazer to cv mode. Set the volts on the trailblazer. Hook your ground clamp and voltage sensing wire to your work. Electrode lead to the feeder. Set wire feed speed on the feeder. Set up shielding gas if your running dual shield wire. Purge the gas line and gun. Pull the trigger and start welding.
    Lincoln Idealarc 250
    Miller Bobcat 250
    Thermal arc Hefty 2 feeder
    Thermal Dynamics Cusmaster 52
    Torchmate CNC Table

    Comment


    • #3
      Originally posted by 6805eagleguy View Post
      ... suitcase is trying to put out 60 or 65 volts no matter where I set the trailblazer...
      How are you measuring this and at what point in time?

      Comment


      • #4
        When the trailblazer is idling the suitcase digital display reads anything from 60 volts to 95 volts. The suitcase will almost kill the trailblazer because the trailblazer will only put out 35 v. Trying to put out 60 volts does not work on the trailblazer end.

        Comment


        • #5
          I had it working a couple days ago but am trying to work today and it is not working at all

          Comment


          • #6
            You can only tell the arc volts shown on the feeder while your welding. You would have to have someone else read it for you while your welding.
            Lincoln Idealarc 250
            Miller Bobcat 250
            Thermal arc Hefty 2 feeder
            Thermal Dynamics Cusmaster 52
            Torchmate CNC Table

            Comment


            • #7
              Sounds like the feeder is just showing open voltage. Were you in CV mode on the Trailblazer and did you have the suitcase also set for CV mode? The suitcase won't harm the Trailblazer unless there was some massive, direct short inside the thing. You would know that in a hurry.....
              fence and gate shop worker
              At home...
              Lincoln Power MIG 180....
              Winco 6000 watt generator (13 hp Honda) "Big Jake"

              Comment


              • #8
                Finally got it to work on a different trailblazer.

                pounded out 60 lbs of wire.

                Thanks for the Help!

                Comment

                Working...
                X