Announcement

Collapse
No announcement yet.

Handler 125 EZ stopped working

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Handler 125 EZ stopped working

    I purchased this welder new about 5 years ago and it has worked great for me. As I try to weld, the welder buzzes, doesn't push the wire out and then turns off. I can hear the overload protector trip. This happens within a few seconds of pressing the trigger.

    Is there anything I should check prior to taking it in for service?


  • #2
    Originally posted by Jneiman View Post
    I purchased this welder new about 5 years ago and it has worked great for me. As I try to weld, the welder buzzes, doesn't push the wire out and then turns off. I can hear the overload protector trip. This happens within a few seconds of pressing the trigger.

    Is there anything I should check prior to taking it in for service?
    Yes, you shoud do every thing suggested in the trouble-shooting section of your manul, record results, and then phone Hobart, even though it may be out of warranty. They will tell you if it needs to go in. May be as simple as wire stuck in the liner from non-use.

    Comment


    • #3
      Check the output rectifier diodes. Sounds like one is shorted.

      Comment


      • #4
        Visually, the diodes look normal. I am not sure how to test them. I think I am just going to take it in for service.

        Comment


        • #5
          You will need to isolate them and test with a meter. OR disconnect the two large leads from the rectifier(be sure they do not touch each other or anything else), turn on the unit and squeeze the trigger. If the unit does not trip the reset then the diodes are shorted.

          Comment

          Working...
          X