Announcement

Collapse
No announcement yet.

880-113-666 power suply part id for snap-on ya240a

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    have not taken any voltage measurments yet, still waiting on parts to arrive. on my bd Q2 is completely blown apart literally, the front half of the transistor is gone, D1,D2 read dead shorts along with base to collector junction of Q1

    Comment


    • #17
      replaced parts mentioned in previous post, unit fed fine for about 15 mins and now I have the same parts bad again. 15 and 30 volt lines were good, speed control min and max feed were good. I ordered 2 sets of the transistors and diodes along with all the ICs on the bd from www.newark.com total cost with shipping less than 17 dollars. feed motor did not feel warm to touch immediatly after the transistor shorted. any clues as to what else might be wrong.

      Thanks ,
      mrallen36

      Comment


      • #18
        diagram for control board

        Originally posted by Jake_SS View Post
        If you send me your email address I will send it to you.
        Make sure that you thoroughly check your pcb as compared to the print to make sure they are the same.
        If an IC is blown then likely other components are as well. They may not appear to have any physical damage but perhaps shorted or open circuit.
        Do a lot of testing to see if you can figure out why it failed.

        Cheers
        I am also trying to troubleshoot a ya240a snap-on welder. I think I have narrowed down one of the problems to the control board. I am having problems with the feeder motor running constantly even when I have unplugged all the jacks on the board except for power in and motor out wires. A diagram of the control board would help me greatly. If you could email it to [email protected] I might be able to make some progress.

        Thanks

        Comment


        • #19
          Originally posted by ollison View Post
          I am also trying to troubleshoot a ya240a snap-on welder. I think I have narrowed down one of the problems to the control board. I am having problems with the feeder motor running constantly even when I have unplugged all the jacks on the board except for power in and motor out wires. A diagram of the control board would help me greatly. If you could email it to [email protected] I might be able to make some progress.

          Thanks
          Im having the exact same problem and i could use that diagram myself [email protected]

          Comment


          • #20
            Did any of you try calling Snap-On Customer Support? (chuckle, chuckle)
            "Good Enough Never Is"

            Comment


            • #21
              For years Snap-on welders have been made by CK Systematics. Don't know if they made your welder or still in business.

              CK Systematics, Inc.
              Tel: 610-696-9040
              Fax: 610-430-8714

              1025 Saunders Lane
              West Chester, PA,
              19380-4217

              http://www.macraesbluebook.com/searc...company=306002
              http://www.brweldingsupplies.com/bra...ndex.cfm?id=61

              Originally the company was owned by 2 partners making welders and TIG torches. When partners broke up the company TIG torch manufacturing and sales became CK WORLDWIDE
              http://www.ckworldwide.com/

              Comment


              • #22
                Snap on welder YA240A

                Having problem with wire feed running consistently. Have any ideas?

                Comment


                • #23
                  Did you fix the problem

                  Originally posted by ollison View Post
                  I am also trying to troubleshoot a ya240a snap-on welder. I think I have narrowed down one of the problems to the control board. I am having problems with the feeder motor running constantly even when I have unplugged all the jacks on the board except for power in and motor out wires. A diagram of the control board would help me greatly. If you could email it to [email protected] I might be able to make some progress.

                  Thanks
                  Having to same issue. Any help is great.

                  Comment


                  • #24
                    does anyone know if the 880-113-666 control board controls the power at the trigger also because im not getting any ark and my feed motor is working ok there was a bad lightning strike now it wont weld hope i can get some help thanks

                    Comment

                    Working...
                    X