Announcement

Collapse
No announcement yet.

Wire feed problems

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wire feed problems

    Hello. my first post. Just found this forum and was hoping somone can help me with this problem. I have an italian made (I believe) chicago electric dual mig 200 welder model 93804. (I know it's not a Hobart, but it is what it is.) Anyway, It was working good for a year or so and now the wire feed quit working. It powers on and will strike an arc, etc but no feed. I disconnected the wire feed motor and touched it up to a 12v battery and the motor works, so I assume it's the controller, but not real up on electronics and don't know where to start. I am including a picture of one small pcb and was wondering if that is the dc controller board and another picture of the main pc board. There is also another board with the relays. When I press the trigger I can hear the relays clicking. If I'm not mistaken I can hear the gas solinoid working too, but not 100% sure on that. I tried testing the voltage and get 25V AC everywhere and no DC voltage anywhere. Any ideas where to start. I know these are disposable welders, but all I can afford right now and need to try to get it going. any help will be much appreciated.
    thanks
    Robert

  • #2
    Call the technical help line for your welder and they will help you find problem and sell you repair part.

    Buy another welder and just like yours. Compare and record circuit board voltage readings between your old welder and new welder both with trigger switch on and off until you find problem. Buy parts and repair old welder. Return one of your welders for refund. Wires from voltage speed control might help you locate problem.

    Comment

    Working...
    X