Announcement

Collapse
No announcement yet.

Wire Feeder Roller seized?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Wire Feeder Roller seized?

    I have a 140 mig and the feed on it is broken the roller to feed the wire wont roll when i pull the trigger or try and turn it. It must be seized. I purchased it off of Toolking two years ago (reconditoned) so $400. Would it be worth fixing or parts and labor worth it? Any help or suggestions would be appreciated.

  • #2
    The wire drive uses a gearmotor to run the feed roll so you'd be unlikely to be able to turn the feed roll by hand. The likelihood of it being "seized" is minimal, you've probably got something else at play. Check to be sure the voltage switch is firmly clicked into one of the detents and not halfway between selections, for starters.
    Trailblazer 302 * Millermatic 212 * Syncrowave 180SD * X-Treme 12VS Feeder * Spoolmate 3035
    Thermal Dynamics Cutmaster 52 Plasma * Lincoln 175 MIG

    Victor Superrange II * Victor Journeyman

    Hobart HH 125EZ


    Comment


    • #3
      ...and try it with no tension to see if the wheel turns.
      "Good Enough Never Is"

      Comment


      • #4
        i tried that but it didnt turn either

        Comment


        • #5
          ???? any other suggestions?

          Comment


          • #6
            OK, so the unit is turned on, the drive roll is totally slacked of, and when you pull the trigger the wheel does not turn...

            Is there a "click" when you pull the trigger? (That would be the gas solinoid, and means that you gun switch is working)

            Is it set on "Purge"? (If so, no wire moves, its just for gas flow...set on a # on the dial)
            Have you tried different wire speed settings on the switch? (Do not switch while holding the trigger down, though).

            Is there any indication that the unit is getting/not getting power? (fan on?)

            Have you tried in on a different outlet on a separate circuit?
            "Good Enough Never Is"

            Comment


            • #7
              Yes i tried with it slacked off and it does click each time i press the trigger. the fan automatically turns on when i turn it on. I cant find any indication of loss of power, i have tried it on several outlets.

              Comment


              • #8
                I think you have done all you can do at this point...tomorrow is Monday, so contact Hobart then, and perhaps Hobart Experts will beat you to the draw on the forum...my guess (and its only that) is the controller board, but it could be the drive motor... Any chance a wire came loose??

                If I remember correctly, the drive motor is NOT 110 volt, but rather a DC unit, so you cannot simply jumper to it to see if its working...you could put a voltmeter on the inputs to that motor to see if its getting its shot when you pull the trigger...if not...Controller Board.
                "Good Enough Never Is"

                Comment


                • #9
                  First make certain the unit is disconnected from input power. Then remove the side cover and look for a disconnected wire.
                  MigMaster 250- Smooth arc with a good touch of softness to it. Good weld puddle wetout. Light spatter producer.
                  Ironman 230 - Soft arc with a touch of agressiveness to it. Very good weld puddle wet out. Light spatter producer.


                  PM 180C



                  HH 125 EZ - impressive little fluxcore only unit

                  Comment


                  • #10
                    Motor will not turn

                    Have you looked to see if there a fuse in the circuit as a lot of sets have a fuse or overload trip in the circuit ,its very rare for a wire feed motor to break down.

                    Comment

                    Working...
                    X